博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
求回文数
阅读量:4971 次
发布时间:2019-06-12

本文共 903 字,大约阅读时间需要 3 分钟。

题目出处:桂电oj,网址:http://onlinejudge.guet.edu.cn/guetoj/problem/view/1029.html

Description

给你一个数字,你要判断它是不是回文数字。例如134431或者242这种左右对称的数就叫做回文数。

现在你需要编写一个程序判断输入的数字是否为回文数。你需要判断输入的n是不是回文数字,如果是,请返回1,否则请返回0

Input

输入要判断的数,其中数的长度是未知的。

Output

是回文数输出1,否则输出0

Sample Input

123

12321

Sample Output

0

1

#include <iostream>

#include <cstring>
using namespace std;
int Is_huiwenshu(char a[1024]);
int main()
{
    char x[1024] = {0};
    cin >> x;
    cout << Is_huiwenshu(x) << endl;
    return 0;
}
int Is_huiwenshu(char a[1024])
{
    char b[1024] = {0};
    int i= 0;
    int len = strlen(a);
    int len1 = len;
    while ( len > -1 )
    {
        b[len-1] = a[i];
        i++;
        len--;
    }
    for (int j = 0;j < len1;)
    {
        if (a[j] == b[j])
        {
             j++;
             if (a[j] == '\0' &&b[j] == '\0')
             {
                 return 1;
             }
        }
        else
            return 0;
    }
}

This is what I think,

if you got a better idea, could you please send an E-mail to ediszhao@sina.com for my to learn.

转载于:https://www.cnblogs.com/ediszhao/p/3481421.html

你可能感兴趣的文章
php面向对象一,private,public,protected,__construct,__destruct
查看>>
String to Integer (atoi)
查看>>
IIS 使用Let's Encrypt并配置HTTP跳转HTTPS
查看>>
(转)Android 仿订单出票效果 (附DEMO)
查看>>
高薪是怎么跳出来的
查看>>
jvm栈-运行控制,jvm-堆运行存储共享单元
查看>>
数据库多张表导出到excel
查看>>
jekyll bootstrap更改主题theme
查看>>
POJ1300(欧拉回路)
查看>>
HDU 1598 find the most comfortable road (最小生成树) &gt;&gt;
查看>>
数码管 键盘 十进制计数
查看>>
算法7-10:拓扑排序
查看>>
快速智能数据导入工具1.0
查看>>
态度决定品质
查看>>
NPOI Excel 单元格背景颜色对照表
查看>>
微信小程序去除button默认样式
查看>>
11/26
查看>>
Where does Visual Studio look for C++ Header files?
查看>>
JSP生成Excel报表
查看>>
Java打包可执行jar包 包含外部文件
查看>>